[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#492294: dbg package dependancy advice incorrect

Package: developers-reference
Version: 3.4.0
Severity: normal


The end of section 6.7.9 contains a mistake, or is unclear.  It says:

    Note that the Debian package should depend on the package that it
    provides debugging symbols for, and this dependency should be
    versioned. For example:

    Depends: libfoo-dbg (= ${binary:Version})

This is backwards.  The _debug_ package should depend on the package(s)
providing the programs or libraries matching the symbols it contains.
The example should read:

    Package: libexample-dbg
    Depends: libexample (= ${binary:Version})


Reply to: