[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help wanted: Cannot use 'man' cmd

Hi All,

On Tuesday 03 April 2001 00:50, siward wrote:
> Hi,
>   with all due respect Wichert,
>   i.e. i'm not saying i know better than you,
>   i run as root nearly always and man has worked without any problem.
>   i have frequently used it, directly and as input to a pipe.
>   what problem should i have that i haven't ?

I thinks that's why you should look at the man of man (maybe broken database 
or access rights problems or anything, dont know but the man could help...)

According to the message, man is trying to create a temporary file (dont know 
where : maybe it stands in the man or in an environment variable specified in 
the man) - and has no right to do it. Who owns this directory ? Isn't this 
directory a read-only mounted device ? Or a network share you dont have 
enough access to ?

>   if not, then you might do
>     man man > somefile

man man | col -bx >> essai.txt      

Will allow to remove the special characters (doubled characters and so on) : 
already less rude :)

>     (where somefile is a file that already exists and permits write to
> everybody)
>     and then read the file with an editor.
>   it is crude but it works.
>   i use this often myself,
>     except that i pass  the output from man to a small program that
>       converts man page to normal text,
>     so i dont have to do that by hand.
>   it's great for writing notes in the manual.
>   have fun !
>     Siward.
> ________________________________________________________
> Wichert Akkerman wrote:
> > Previously Guenter Millahn wrote:
> > > myhost# man ls
> > > man: can't create a temporary filename: Permission denied
> >
Knowledge-sharing and open-source content : another way to gain eternity.
Francis "Dexter" Gois - mailto : fg@tiscali.be
System Administrator  -  Tiscali Belgium NV/SA
phone: +3224000839    -      fax : +3224000899 

Reply to: