[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: transition to usrmerge to start around 2022-09-15 (next Thursday)

On Thu, 2022-09-15 at 22:57 +0100, Luca Boccassi wrote:
> On Sat, 2022-09-10 at 15:37 +0200, Ansgar wrote:
> > Hi,
> > 
> > the transition to usrmerge as described in [1] is planned to start
> > around 2022-09-15 (next Thursday).
> > 
> > init-system-helpers 1.65~exp1 in experimental adds the new dependency
> > on
> > "usrmerge | usr-is-merged" and will be uploaded to unstable to start
> > the
> > transition. Feel free to test and report any issues.
> > 
> > Recent versions of debootstrap[2] will setup the usr-is-merged
> > package to
> > avoid installing additional dependencies required by usrmerge. The
> > usr-is-merged package can also be manually installed in existing
> > systems
> > for the same reason.
> > 
> > Debian's buildds will continue to use the legacy filesystem layout
> > for
> > Debian 12 (bookworm).
> > 
> > We will send an announcement to debian-devel-announce@ once the
> > upload
> > to unstable happens.
> > 
> > Ansgar
> > 
> >   [1]: https://lists.debian.org/debian-ctte/2022/09/msg00005.html
> >   [2]: debootstrap 1.0.114+deb10u1, 1.0.123+deb11u1, 1.0.127
> Quick update: three minor issues where found, two with i-s-h itself
> (one solved in experimental just now about test deps uninstallability
> on some ports and one piuparts seemingly false positive about
> /etc/shells that I'll fix tomorrow), and one in usrmerge+nspawn+arm64
> [0]. I have just come back home from LPC so did not have much time
> today, will have a look at the latter two tomorrow and then upload to
> unstable once the situation is clearer.
> [0] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1019575

All 3 issues are solved or pending:

1) init-system-helpers build issue on some ports architectures has been
fixed (new test dependency fakeroot is not available everywhere, made

2) salsa CI issue with piuparts job image not being built by
debootstrap/mmdebstrap and thus not installing usrmerge/usr-is-merged,
causing a false positive when usrmerge is pulled in by the package-
under-test thus falsely attributing the /etc/shells change to it, fixed
by installing usrmerge in the pre-built image, MR pending:

3) systemd-nspawn on aarch64 merged systems creates a /lib64 ->
/usr/lib/aarch64-linux-gnu symlink which is not created by
debootstrap/mmdebstrap, so the usr-is-merged preinst check doesn't
expect it and erroneously fails. Fixed with NMU to just enforce that
the arch-specific libdirs are symlinks to /usr/lib* instead of exactly
the same dirname under /usr, as this is not the right place to care
about that detail, the only important thing in this context is the
target being under /usr.

Unless any new issue pops up, I'll upload i-s-h to unstable to start
the transition tomorrow evening.

Kind regards,
Luca Boccassi

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: