[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem building a Debian package in AFS

I have two Debian servers: one is buster and one is bullseye. They both run the openafs-client service. When I run "gbp buildpackage mypackage" it completes successfully on both servers as long as the directory where I run "gbp" is _not_ in AFS. If I run "gbp" in an AFS directory it completes successfully on the buster server but fails almost immediately if run on the bullseye server.

The failed build output on the bullseye server looks like this:
test2-bullseye:~/development/git/vemail> gbp buildpackage
dh clean
gbp:info: Exporting 'HEAD' to '/afs/example.com/users/rlinxster/development/git/build-area/email-virtual-domain-tmp' gbp:info: Moving '/afs/example.com/users/rlinxster/development/git/build-area/email-virtual-domain-tmp' to '/afs/example.com/users/rlinxster/development/git/build-area/email-virtual-domain-11'
gbp:info: Performing the build
Building with cowbuilder for distribution sid
I: using cowbuilder as pbuilder
dh clean
dpkg-source: info: using source format '3.0 (native)'
dpkg-source: info: building email-virtual-domain in email-virtual-domain_11.tar.xz dpkg-source: info: building email-virtual-domain in email-virtual-domain_11.dsc I: Generated dsc will be overwritten by build result; not generating changes file
E: File not found: ../email-virtual-domain_11.dsc
gbp:error: 'git-pbuilder' failed: it exited with 1

Here is my .gbp.conf (same on both servers):
builder = git-pbuilder
cleaner = fakeroot debian/rules clean
pristine-tar = True

export-dir = ../build-area/
tarball-dir = ..

dch = False

Reply to: