Re: Bug#851306: ITP: freebayes -- Bayesian haplotype-based polymorphism discovery and genotyping
Scott Kitterman dijo [Sun, Jan 15, 2017 at 04:34:40PM +0000]:
> >> "freebayes" seems like a very generic name for something specific to
> >such a
> >> narrow field. Maybe freebayes-genetic-variance or some such instead.
> >I fully agree with your generic name consideration. The software is
> >well known in this work field anyway so I'm hesitating a bit to rename
> >it. Would you consider this a strong issue that needs to be discussed
> >with upstream or is it in a "not nice but acceptable" status?
> I think it should be discussed with upstream, but we have broader
> namespace considerations that they may not understand or care about.
> As long as a package search for freebayes returns this in the result
> set, I don't think it's critical to have the package name match
> exactly the upstream name.
> Not wearing my FTP team hat for this, consider it as a comment from
> another DD.
As Scott is not "officially" speaking from the FTP team but just as a
DD, I'll chime in here.
I think the package name should indicate the field for which it is
meant (freebayes-genetic-variance), but I don't think the program name
should deviate from upstream; we have had issues such as when node.js
was introduced (that 'node' was a name already taken by another
program), but I don't think 'freebayes' will be such a contentious