[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#782264: grub-install fails in nested LVM

Le 9 avril 2015 18:05:50 GMT+02:00, "Pierre-Elliott Bécue" <becue@crans.org> a écrit :
>Source: grub
>Version: 2.02~beta2-22
>Severity: important
>Dear maintainer,
>I've met a bug in GRUB under a Proxmox environment, which I was able to
>reproduce under a clean Debian system (my laptop, under jessie).
>With Proxmox, I needed to build a nested LVM storage for my VM, that
>in the host point of view :
>/dev/sdxx (physical) -> first volumegroup (vg1) -> A single logical
>volume (lv1)
>(the guest physical disk) -> a single partition (lv1p1) -> a second
>volumegroup (vg2)
>-> logical volumes containing guest data. (slash, var, swap)
>For the guest, the single logical volume (lv1) is seen as the physical
>disk of the VM, named /dev/vda when the VM is started.
>Under wheezy, I was able to debootstrap wheezy on the disks, and to
>chroot in them to make a grub-install on lv1.
>Under jessie, I get an error :
>grub-install: error: disk
>not found.
>I first thought it was a bug due to Proxmox VE. So I tried to build a
>proof of concept on my Jessie laptop, using an external drive. The
>problem is the same.
>I tried to git clone the grub repo and to compile it to try a
>grub-install, and this one worked. So it seems that grub 2.02~beta2-22
>is broken.
>I'm not able to say if it comes from Debian patches or from the actual
>upstream code, but it seems this problem is important enough to be
>I'll be happy to provide you with more data if I can.


It's been more than 10 months and still nothing (even a simple ack).

Could you consider adding a stable version of grub in a partial release of Jessie?


Reply to: