[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GPL-3 & openssl: provide a -nossl variant for a library



* Michael Fladischer:

> Considering this, is it a good idea to provide a librabbitmq1-nossl
> binary package that was built without OpenSSL while still having
> librabbitmq1 with OpenSSL-support?

We do not do this for Python, which links against OpenSSL, and which
is used from software under the GPL, so I don't really see why we have
to do this for other infrastructure components.

The long term solution is to rely on the system library exception to
regain GPL compatibility, just as Fedora does.  It's really
unavoidable with libraries moving to (L)GPLv3 and the presence of
GPLv2-only software in Debian.


Reply to: