[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

The inittab interface - Re: Bug#766187: runit: Fails to install runit after fresh install of jessie beta2

severity 766187 grave

On Tue, Oct 21, 2014 at 08:29:54AM -0400, Nikolay Hristov wrote:
> Fresh minimal install of Jessie Beta2 with only SSH server selected in tasksel.
> Tried to install runit with 'apt-get install runit' and apt-get exits with error 
> message of missing /etc/inittab and leaves it unconfigured.

> root@tre:~# apt-get install runit
> Setting up runit (2.1.2-1) ...
> grep: /etc/inittab: No such file or directory
> grep: /etc/inittab: No such file or directory
> cp: cannot stat ‘/etc/inittab’: No such file or directory
> dpkg: error processing package runit (--configure):
>  subprocess installed post-installation script returned error exit status 1
> Errors were encountered while processing:
>  runit
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> root@tre:~#

Hi, thanks for the report.

I not yet have an idea how to fix this, hope you can help finding a

Since ages runit hooks into /etc/inittab to provide system wide service
supervision.  As long as sysvinit provided /etc/inittab and was
essential this simply worked.  Now on fresh jessie install, no
/etc/inittab is created at all.  While this alone wouldn't be a problem,
because runit provides a simple systemd unit after I learned that
there's no backward compatibility to the /etc/inittab interface, it is a
problem when switching such an installation from systemd to sysvinit:

When switching to sysvinit, the /etc/inittab file is created, but
doesn't include the lines enabling the runit supervision.  After reboot
runit supervision will not be enabled, although the package is
installed.  This would be a grave bug as other packages depend on this

Any idea on how to fix this?

Thanks, Gerrit.

Reply to: