[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CUPS is now linked against OpenSSL (and will stay GPLv2-only)



On Sun 2013-12-22 14:12:40 -0500, Andreas Metzler wrote:

> #3 Hope that GMP is relicensed to GPL2+/LGPLv3+

On Tue 2014-01-14 04:53:51 -0500, Didier 'OdyX' Raboud wrote:

> 2) GnuTLS
>    2.x is useable but deprecated, 3.x is GPLv3+ through GMP. We're back
>    to "talk to the FSF to license GMP back to LGPLv2+"

I think OdyX is asking for more from GMP than is necessary; note that
Andreas earlier pointed out that GMP just needs to be GPL2+/LGPLv3+.

This is exactly what libgmp (in particular, Torbjorn Granlund
<tege@gmplib.org>) appears to have decided to do as of yesterday:

Changelog:
  https://gmplib.org/repo/gmp/rev/02634effbd4e
Huge diff with licensing changes:
  https://gmplib.org/repo/gmp/rev/da670a8513db 

So i believe this makes the GPLv2-only CUPS re-distributable again when
linked to modern versions of GnuTLS.

Happy Hacking,

       --dkg

Attachment: pgpQJ6jUx_9v5.pgp
Description: PGP signature


Reply to: