[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#735927: general: xserver-xorg-video-intel crashes when shared dynamic video ram runs out

Control: reopen -1
Control: reassign -1 xserver-xorg-video-intel 2:2.19.0-6
Control: retitle -1 xserver-xorg-video-intel: X crashes under memory pressure

Hi moli,

thanks for the further tests. I'm reopening and reassigning this bug 
report from 'general' to the intel driver, moving the discussion from 
the main debian development mailing list to the driver maintainers.
I'm sorry, but I cannot help you digging further into X and the intel
driver to get this fixed. That's not my playground :-)

On 2014-01-20 02:20, moli wrote:
>> Could you try the vesa (xserver-xorg-video-vesa) driver instead and
>> see what happens under extreme memory pressure?
> Excellent idea, dont know why i havent done this already. That's why i
> turned to you for help. btw this is my first time on debianbts, so i'm
> sorry if i do something out of etiquette - my bad english does not help
> either.
> I uninstalled xserver-xorg-video-intel as i'm dumb and dont
> know how to disable a driver (tried blacklist but dont know the module

You would have to create an xorg.conf, but removing the package is a 
valid option as well :-)

> name, googled, nothing, so), i rebooted, tried to crash the system,
> opened 7 youtube videos, chrome got killed, X survived. Just like on my
> other systems and OSes.
> So it seems proven that the intel driver is the problem. Maybe because
> vesa driver doesnt use dynamic video memory only a fixed size small one?

Good (well, at least knowing which package is at fault).

> # apt-get install xserver-xorg-video-intel/jessie
> but apt-pinning did not work, since it requires update of libc.
... and updating the full Xorg stack to the jessie versions ...
Mixing stable and testing is not recommended and not supported!

Since there are no wheezy-backports for your package available, you did 
the right thing:

> So, i did:
> # apt-get install dpkg-dev
> # apt-get build-dep xserver-xorg-video-intel/jessie
> # apt-get -b source xserver-xorg-video-intel/jessie
> # dpkg -i xserver-xorg-video-intel_2.21.15-1_amd64.deb
> Guys, did i do this right? This building thing?

Looks good.

> I rebooted and ran the test, it did not crash. As i started to rejoice,
> i realized, i'm probably using the vesa driver, so still not knowing
> how to specify or even list the driver to use, i removed the
> xserver-xorg-video-vesa package and rebooted. It crashed just like with
> the old driver.

IIRC the vesa driver will only be used as a last resort, but you seem 
to have experienced something different.
The logfile /var/log/Xorg.0.log should contain (among many other 
things) which driver is being used in the currently running X server

Is vesa a usable workaround? Or is it horribly slow?


Reply to: