[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

pdksh transitional package going away...

Andreas Henriksson dixit:

>I intend to drop the iproute transitional packages in Jessie+1.
>This message is here to give all 68 packages depending/recommending/suggesting

Ah, good idea, to remind people again.

I intend to drop the pdksh transitional package in between the
time Ubuntu 14.04 LTS (I assume 17 April 2014) is released and
the freeze for Jessie will be enacted, with the assumption there
is some time in between these two.

The reason for this is that, by then, the pdksh transitional
package will have been in a stable version in both distros.

In Debian, there are only two packages depending, recommending,
suggesting or build-depending on pdksh right now:

Christoph Egger <christoph@debian.org>
   graphviz (U)

David Claughton <dave@eclecticdave.com>

Sebastian Harl <tokkee@debian.org>
   graphviz (U)

Ulrich Dangel <mru@spamt.net>

Furthermore, one package has an alternating dependency with
pdksh already lower priorised than mksh, and ksh93 has a
versioned conflict on pdksh which thus is not an issue.

I would like to ask the aforementioned maintainers to transition
to depending/build-depending on mksh instead and try to use the
mksh binary for their scripts, and the lksh binary otherwise (i.e.
if they are scrips requiring the legacy behaviour). I will assist
with adjusting scripts, of course; please contact me privately or
the miros-mksh (at) mirbsd (point) org mailing list (no subscription

20:49⎜«Natureshadow» Oops, jetzt hab ich mir doch glatt beim Trinken
     ⎜    Mineralwasser ins Ohr gekippt…
21:04⎜«mirabilos» ist das siggbar?
21:05⎜«Natureshadow» mirabilos: was sollte dich davon abhalten…

Reply to: