[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#719673: ITP: needrestart -- needrestart checks which daemons need to be restarted after library upgrades

On Thu, Aug 22, 2013 at 11:17 AM, Matthias Klumpp wrote:

> PackageKit can do that ;-) It has a plugin to check for shared
> libraries in use, I just haven't tested in yet. It should show the
> names of services which need to be restarted after a security update.


> This info is at least shown on the command line (and only for security updates).

How does it know if an update fixes a security issue? Just checking if
it comes from security.d.o would not be enough since updates to
unstable often fix security issues. I guess it uses the
debsecan/security-tracker data?


Reply to: