[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Algorithm for selecting between packages providing the same phpapi-20100525, change between squeeze -> wheezy

On Tue, Jul 9, 2013 at 5:36 PM, Julien Cristau <jcristau@debian.org> wrote:
On Tue, Jul  9, 2013 at 14:25:59 +0200, Ondřej Surý wrote:

> David,
> will this bug get fixed in wheezy?
> More people are starting to complain they get libapache2-mod-php5filter
> installed: #709027
> I am still have no idea how to fix that in wheezy apart from fixing the
> selection algorithm in apt.
I'm pretty sure what needs to happen here is to have exactly one package
providing phpapi-20121212.

You are quite right. I have prepared an php5 upload where only php5-common package provide phpapi-20121212 and the Provides: part have been dropped from various SAPIs.

This will of course break all packages depending only on php5-<module> without declaring dependency on php5 (or specific php5 SAPI). After cleaning the list (grep-dctrl generated) by removing php libraries and various optional modules, where the php5 dependency is provided by main package (like fusionforge, mediawiki, nordugrid, horde), I have been left with this list:

> Package: bandwidthd-pgsql
> Depends: dbconfig-common, php5-gd, postgresql-client, ucf, debconf (>= 0.5) | debconf-2.0, libc6 (>= 2.14), libgd3 (>= 2.1.0~alpha~), libpcap0.8 (>= 0.9.8), libpng12-0 (>= 1.2.13-4), libpq5

> Package: davical
> Depends: debconf (>= 1.0.32), php5-pgsql, postgresql-client (>= 8.1), libawl-php (>= 0.53-1~), libawl-php (<< 0.54), libdbd-pg-perl, libyaml-perl

On the other hand it will fix all packages declaring "Depends: php5-<module>, php5" since the php5 SAPI dependency will be correctly resolved by dependency order in php5.

We might be able to do the same for wheezy if we can push the fix for bandwidth-pgsql and davical to wheezy in the same run. That's probably up to release team to say if they would ack such action.

Ondřej Surý <ondrej@sury.org>

Reply to: