[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Algorithm for selecting between packages providing the same phpapi-20100525, change between squeeze -> wheezy

On Tue, Jul 9, 2013 at 2:25 PM, Ondřej Surý <ondrej@sury.org> wrote:
> will this bug get fixed in wheezy?

Just asked Michael about it again as we forgot about it for the last one,
but as said, you are depending on an implementation detail of libapt,
so this isn't going to fix your problem if another solver is used
(e.g. aptitude [as it isn't using the relevant code] or an external solver).

So just to repeat myself:
Policy isn't defining which provider should be chosen, its assumed that
the maintainer is expressing a preference or if not that ANY provider
can be chosen based on whichever criteria the solver might want.

(Still no checked what aptitude uses, but I bet its some sort of
 'least disruptive changes' which is obviously better than priority
 alone, but not at all working in your favor of course)

Best regards

David Kalnischkies

Reply to: