[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Checking license compatibilty of (indirect) rdepends


I have tried in the past to find out what would break in Debian if we
used a GnuTLS library which was licensed LGPLv3+ instead of LGPLv2.1+. I
started going through packages (build-)depending on libgnutls-dev and
reading their debian/copyright, checking for incompatible licenses.

However after that there are still the indirect dependencies to
consider, and which of these acually include a binary that ends up
being dynamically linked to gnutls at runtime.

Do we have something better than manual checking? (I do not think so,
as the required info is not necessarily part of DEP-5 copyright files,
but would welcome a positive surprise.)

thanks, cu Andreas
`What a good friend you are to him, Dr. Maturin. His other friends are
so grateful to you.'
`I sew his ears on from time to time, sure'

Reply to: