[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Candidates for removal from testing (2013-01-24)

On Thu, Jan 24, 2013 at 9:47 AM, Niels Thykier <niels@thykier.net> wrote:
> Debian QA Group <packages@qa.debian.org>
>    bzr-gtk

>   --8<----8<-- removals --8<----8<--
> # #697402
> remove bzr-gtk/0.103.0+bzr792-3

As jwilk has already mentioned in the bug report, [1] this should be
assigned elsewhere. Though, it is not exactly clear where.

To briefly summarize, the bug is that having bzr-gtk and python-gtk2
installed at the same time causes "pydoc -k foobarbaz" to crash. This
is because pydoc imports all packages in order to find out what
modules they contain. bzr-gtk imports gi.repository.Gtk. This loads
libgtk-3.so.0 and python-gtk2 obviously loads libgtk-2. Presumably any
other python package using GTK+3 would cause this crash, not just

Any guidance would be appreciated.

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=697402#15


-- Andrew Starr-Bochicchio

   Ubuntu Developer <https://launchpad.net/~andrewsomething>
   Debian Developer <http://qa.debian.org/developer.php?login=asb>

Reply to: