[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#696089: ITP: libdevel-declare-parser-perl -- higher level interface to Devel::Declare

Package: wnpp
Owner: gregor herrmann <gregoa@debian.org>
Severity: wishlist
X-Debbugs-CC: debian-devel@lists.debian.org,debian-perl@lists.debian.org

* Package name    : libdevel-declare-parser-perl
  Version         : 0.17
  Upstream Author : Chad Granum <exodist7@gmail.com>
* URL             : https://metacpan.org/release/Devel-Declare-Parser/
* License         : Artistic or GPL-1+
  Programming Lang: Perl
  Description     : higher level interface to Devel::Declare

Devel::Declare::Parser is a higher-level API sitting on top of
Devel::Declare. It is used by Devel::Declare::Exporter to simplify exporting
of Devel::Declare magic. Writing custom parsers usually only requires
subclassing this module and overriding a couple methods.

Reply to: