[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#689711: ITP: libarray-iterator-perl -- simple class to provide iterators over Perl arrays

Package: wnpp
Owner: Dominique Dumont <dod@debian.org>
Severity: wishlist
X-Debbugs-CC: debian-devel@lists.debian.org,debian-perl@lists.debian.org

* Package name    : libarray-iterator-perl
  Version         : 0.8
  Upstream Author : Steven Haryanto <stevenharyanto@gmail.com>
* URL             : http://search.cpan.org/dist/Array-Iterator/
* License         : Artistic or GPL-1+
  Programming Lang: Perl
  Description     : simple class to provide iterators over Perl arrays

Array::Iterator Perl module provides a very simple iterator
interface. It is uni-directional and can only be used once. It
provides no means of reverseing or reseting the iterator. It is not
recommended to alter the array during iteration, however no attempt is
made to enforce this. This class only intends to provide a clear and simple
means of generic iteration, nothing more (yet).

This package also provide:
 * Array::Iterator::BiDirectional to allow forwards and backwards iteration
 * Array::Iterator::Circular to allow circular iteration
 * Array::Iterator::Reusable to allow reuse of iterators

This package is a dependency of PIthub which is a dependency of new version of 
git padre plugin

 https://github.com/dod38fr/   -o- http://search.cpan.org/~ddumont/
http://ddumont.wordpress.com/  -o-   irc: dod at irc.debian.org

Reply to: