[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#685186: IA64 (Itanium) Wheezy, ELILO installation failed, patch proposal

Julien Cristau wrote:
>On Sun, Aug 19, 2012 at 17:07:00 +0200, Stephan Schreiber wrote:
>> The failed command is in debian/elilo.sh:
>> fstype=vfat
>> ....
>> mount -t "$fstype" -o
>> codepage=437,iocharset=iso8859-1,rw,noexec,umask=077$loop "$boot"
>> "$TMP/bootstrap.$$"
>> what is perfect to mount an EFI system partition - much better than UTF-8.
>> A mount -t vfat -o codepage=437,iocharset=iso8859-1 needs the kernel
>> modules nls_iso8859-1, nls_cp437, vfat, fat.
>> I ran the installer again. After the ELILO error message I tried
>> lsmod
>> on the shell; the most importand lines that it reported were:
>> nls_cp437
>> vfat
>> fat
>> nls_utf8
>> The nls_iso8859-1 module was not loaded.
>> The existing fat-modules-3.2.0-3-itanium-di.udeb includes the
>> following modules:
>> nls_utf8.ko
>> nls_cp437.ko
>> fat.ko
>> vfat.ko
>> There isn't a nls_iso8859-1.ko.
>< bwh> 'iocharset=iso8859-1' is a bug; Linux standard character encoding
>       is UTF-8
>< bwh> for filenames, at least
>< bwh> So, assign to whatever contains the debian/elilo.sh script
>So reassigning to elilo.

Ah, OK. I saw this while getting elilo to work for amd64/efi too, and
assumed it was working ok on ia64. :-)

Steve McIntyre, Cambridge, UK.                                steve@einval.com
Google-bait:       http://www.debian.org/CD/free-linux-cd
  Debian does NOT ship free CDs. Please do NOT contact the mailing
  lists asking us to send them to you.

Reply to: