[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

I just broke the bts (Fw: /bin/htpasswd exists in apache2-utils ans mini-httpd)

Hi there, 

this Bugreport (see below) seems to break the bts [1]
just for the record.

kind regards,

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=674515


Beginn der weitergeleiteten Nachricht:

Datum: Fri, 25 May 2012 09:22:18 +0200
Von: Michael Stummvoll <michael@stummi.org>
An: submit@bugs.debian.org
Betreff: /bin/htpasswd exists in apache2-utils ans mini-httpd

Package: mini-httpd,apache2-utils
Severity: normal

Dear Maintainers,

two different binaries with the same name /bin/htpasswd are provided by
apache2 and mini-httpd.
If you install mini-httpd after apache2 the htpasswd from mini-httpd
will override the file from apache2.
The file from apache2 is downward-compatible to the from mini-httpd.
This means it provides all the options like mini-httpd, but mini-httpd
does not provide all options from apache2. So it doesn't make any sense
the the htpasswd from mini-httpd overrides that from apache2.
I think thats a bug. It could be resolved by let the packages conflict
or let mini-httpd provide something like mini-htpasswd (which could get
linked to htpasswd as long as apache2 does not exists)

kind regards,
Michael Stummvoll

Reply to: