[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#670549: ITP: lua-ldap -- LDAP library for the Lua language



Package: wnpp
Owner: Luca Capello <luca@pca.it>
Severity: wishlist
Usertags: pca.it-authentication

* Package name    : lua-ldap
  Version         : 1.1.0
  Upstream Author : Kepler Project (copyright holder)
* URL or Web page : <http://www.keplerproject.org/lualdap/>
* License         : MIT
  Description     : LDAP library for the Lua language
  This package contains the Lua LDAP library to:
   * Connect to an LDAP server (OpenLDAP or ADSI/WinLDAP);
   * Execute any operation (search, add, compare, delete, modify
     and rename);
   * Retrieve entries and references of the search result.
  .
  This package contains the runtime library.

The license is word-by-word the MIT license, while not explicitly
referring to it:

  <http://www.opensource.org/licenses/mit-license.php>

This package is needed for LDAP authentication in prosody:

  <http://code.google.com/p/prosody-modules/wiki/mod_auth_ldap>

I Cc:ed Enrico Tassi (the maintainer of most Lua packages in Debian and
also the author of dh-lua) and the upstream authors for their
information.  The package follows the Debian Lua policy:

  <http://pkg-lua.alioth.debian.org/policy.html>

Thx, bye,
Gismo / Luca

Attachment: pgpWRRZVqiSkt.pgp
Description: PGP signature


Reply to: