[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

is something wrong with cron.d ?

I have added a cron task to my package via the package xxx.cron file. (I
am using sid)

However, it never gets executed.... (not exactly true, it happened to
occur once...)

In my syslog file I can see:
Apr 12 13:04:01 VM-247 /usr/sbin/cron[2999]: (*system*xgrid) RELOAD
Apr 12 13:10:01 VM-247 /usr/sbin/cron[2999]: (*system*xgrid) RELOAD
Apr 12 13:17:01 VM-247 /USR/SBIN/CRON[3384]: (root) CMD (   cd / &&
run-parts --report /etc/cron.hourly)
Apr 12 13:20:01 VM-247 /usr/sbin/cron[2999]: (*system*xgrid) RELOAD
Apr 12 13:24:01 VM-247 /usr/sbin/cron[2999]: (*system*xgrid) RELOAD
Apr 12 13:29:48 VM-247 /usr/sbin/cron[3478]: (CRON) INFO (pidfile fd = 3)
Apr 12 13:29:48 VM-247 /usr/sbin/cron[3479]: (CRON) STARTUP (fork ok)
Apr 12 13:29:48 VM-247 /usr/sbin/cron[3479]: (CRON) INFO (Skipping
@reboot jobs -- not system startup)
Apr 12 13:46:01 VM-247 /usr/sbin/cron[3479]: (*system*xgrid) RELOAD

My cron file /etc/cron.d/xgrid is correctly loaded ( I tried to update
it several times to force reload).
I even tried to reboot cron service (last lines).
But it never gets executed....

Here is my cron file:
root@VM-247:# more /etc/cron.d/xgrid 
0/5 * * * * root xgrid-graph >/dev/null 2>&1

I added a blank line after my cron definition (or a comment line) as I
have seen there were issues with issues (don(t know if it is still true).

If I execute the command manually it works fine. And anyway, error
should appear in syslog.

could someone tell me if I did something wrong or if it is a cron issue....




gpg key id: 4096R/326D8438  (keyring.debian.org)
Key fingerprint = 5FB4 6F83 D3B9 5204 6335  D26D 78DC 68DB 326D 8438

Reply to: