[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Status of opensync in Debian - mass removal very likely



opensync/multisync is a complete mess, collecting 25 RC bugs between 20
source packages and a collective 17,626 days waiting to enter testing.
dd-list attached.

Summary:
libopensync-plugin-gnokii	1462 days old (needed 10 days)	libopensync0	RC x 2
libopensync-plugin-gpe		1462 days old (needed 10 days)	libopensync0	RC x 2
libopensync-plugin-irmc		976 days old (needed 10 days)	libopensync0	RC
libopensync-plugin-kdepim	1025 days old (needed 10 days)	libopensync0	RC
libopensync-plugin-moto		1207 days old (needed 10 days)	libopensync0	RC x 2
libopensync-plugin-opie		1190 days old (needed 10 days)	libopensync0	RC x 2
libopensync-plugin-palm		1461 days old (needed 10 days)	libopensync0	RC x 2
libopensync-plugin-python	1347 days old (needed 10 days)	libopensync0	RC x 2
libopensync-plugin-sunbird	1456 days old (needed 10 days)	libopensync0	RC x 2
osynctool			765 days old (needed 10 days)	RC
opensync			663 days old (needed 10 days)	RC x 3
libopensync-plugin-xmlformat	754 days old (needed 10 days)	opensync
libopensync-plugin-vformat	768 days old (needed 10 days)	opensync
libopensync-plugin-syncml	755 days old (needed 10 days)	opensync
libopensync-plugin-file		755 days old (needed 10 days)	opensync
libopensync-plugin-evolution2	755 days old (needed 10 days)	libcamel-1.2-23 et al
multisync0.90			825 days old (needed 10 days)	libopensync0	RC x 2
synce-sync-engine		depends opensync, libopensync-plugin-python
libopensync-plugin-google-calendar	libopensync0 (experimental) RC x 3
synce-kpm				depends on synce-sync-engine

Most depend on libopensync0 which does not exist anymore, those which
have been updated are split between libopensync1exp3 and
libopensync1exp7. libopensync1exp3 does not exist, libopensync1exp7 has
3 RC bugs.

If there's no response (I'm NOT expecting fixes, just *some* idea of
whether these RC bugs *can* be fixed and all the packages migrated to
whatever counts as the latest available libopensync version), ALL of
these packages will have to be removed. I'm afraid it's SO unlikely
that anything is going to be truly fixed by Wheezy, the only real
option for a deadline is 7 days to get *SOME* kind of expression of
interest, some idea of a plan. Naturally, if the maintainers wish to
file the removal bugs themselves, that would be appreciated.

I know all of these have already been removed from testing, but the
packages in unstable are completely unusable / not installable. Just
leaving RC bugs in unstable for years should not be acceptable.

There are packages in experimental too but those appear to be gathering RC
bugs as well, so I'll also file removal bugs for those.

-- 


Neil Williams
=============
http://www.linux.codehelp.co.uk/

Attachment: dd-list
Description: Binary data

Attachment: pgpU8dvxvTS9S.pgp
Description: PGP signature


Reply to: