[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Transition to PHP 5.4 starting soon (Re: PHP 5.4 transition in unstable)

On Wed, February 8, 2012 15:00, Thomas Goirand wrote:
> On 02/08/2012 12:50 AM, Filipus Klutiero wrote:
>> Thankfully there's a page being built to track problems in packages
>> that contain PHP code: http://wiki.debian.org/PHP/54Transition
> This is very nice, but how come PHP Lint isn't in Debian?
> It seems to be shipped under a BSD license, so it shouldn't be an issue.

The string "PHP Lint" here refers to invoking php with the -l option,
which is documented as "lint mode": checking input files on PHP syntax. So
if this fails with parse errors, normal execution will also fail on those
same errors.

> Also, for one of the package I'm maintaining, extplorer (which is a nice
> web file manager), it seems to report a false positive, because it's not
> parsing correctly a traditional Chinese string.

If I include() that file in an otherwise empty PHP script and execute
that, I also get the same parse error (PHP from wheezy). Are you sure that
it actually works?


Reply to: