[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#656234: ITP: six -- Python 2 and 3 compatibility library

Package: wnpp
Severity: wishlist
Owner: Colin Watson <cjwatson@debian.org>

* Package name    : six
  Version         : 1.1.0
  Upstream Author : Benjamin Peterson <benjamin@python.org>
* URL             : http://packages.python.org/six/
* License         : Expat
  Programming Lang: Python
  Description     : Python 2 and 3 compatibility library

Six is a Python 2 and 3 compatibility library. It provides utility
functions for smoothing over the differences between the Python versions
with the goal of writing Python code that is compatible on both Python

(I've been doing a bit of Python 3 porting lately, and in the cases
where it's hard to wedge 2to3 into a module's build system I've been
getting kind of bored of repeatedly writing compatibility code that's
already in six.)

Colin Watson                                       [cjwatson@debian.org]

Reply to: