[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

network-manager,ifupdown and bittorrent Was Re: network-manager as default? No!

Hi all,
         I read the whole thread about network manager starting from

I am an average joe/user who has been a Ubuntu user for few years
while migrating to Debian during the Squeeze freeze cycle (about 6
months back) .

The system I run on is a desktop which is connects via ethernet to a
D-Link Modem/Router to net. While reading the thread I saw that there
is something called ifupdown which is managing stuff for me. I get a
dynamic IP assigned each time I log in and the connection is an ADSL
connection which is pretty much one of the main ways to connect to
Internet in India, although with laptops wireless is happening.

Ok, so in the interest of understanding of what's or how things are
happening, I first decided to see the contents of the package ifupdown

$ dpkg -L ifupdown

and then see the manpage of ifup and other things.

Then tried to run the various things as put up in the manpage :-

$  /etc/network/run/ifstate
bash: /etc/network/run/ifstate: Permission denied

It took me quite some time and trying all different things before I came to :-

$ cat /etc/network/run/ifstate


$ /usr/bin/perl /usr/share/doc/ifupdown/contrib/ifstate-check

neither of which tells me much about how things are configured
(something is hidden somewhere) .

Now as a user both the info. I have got doesn't tell me anything.

Its only after much playing around that I come to known ifconfig which
actually tells me what I need to know :-

~$ ifconfig
eth0      Link encap:Ethernet  HWaddr some:alphanumeric:address
          inet addr:ipv4.add.re.ss  Bcast:ipv4.add.re.ss  Mask:
          inet6 addr: another.alphanumeric.address Scope:Link
          RX packets:49733 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48783 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:55630643 (53.0 MiB)  TX bytes:5838151 (5.5 MiB)
          Interrupt:42 Base address:0xsomething

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:445 errors:0 dropped:0 overruns:0 frame:0
          TX packets:445 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:33957 (33.1 KiB)  TX bytes:33957 (33.1 KiB)

 Even though I am/was able to get this, from the past 6 months or so I
have not been able to run bittorrent on this and I do not know the
reason for this. Its a complete mystery to me. I am able to
update/upgrade the system, run .jigdo to update the weekly ISO DVD's
and do all kinds of git and svn stuff but unable to get bittorrent.

Even for the wireless thing, atleast in my country there are no longer
many open WiFi hotspots especially after the 2008 Mumbai attacks as
the terrorists used the wifi to publicize their attack on net.

Why bittorrent is not working still is a mystery to me, any help in
that regard would be appreciated.

The reason I share all of this is as a user I don't really know how my
system is configured and nor does ifupdown make it any way easy for me
to understand how its done. Atleast to me it seems cryptic in the way
its configures stuff and the way the manpages are written. They are
not written for the average joe to make head or tail of.

This is not for or against network-manager, this is just a user's
experience. As can be seen above, I'm no guru, in fact far far away
from that.

Just my 2 paise.
          Shirish Agarwal  शिरीष अग्रवाल
  My quotes in this email licensed under CC 3.0
065C 6D79 A68C E7EA 52B3  8D70 950D 53FB 729A 8B17

Reply to: