[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: linker related changes for wheezy

Le dimanche 27 février 2011 à 17:00 +0100, Matthias Klose a écrit : 
> Fix build failures with ld --as-needed
> - --------------------------------------
> [Note this is not turned on by default]
> Many packages fail to build when the linker is passed --as-needed as the
> default.  These issues are collected at [4] (please tag new issues accordingly).
>  The vast majority of these kind of failures are some assumptions about link
> order with the GNU linker (ld), which may not be fulfilled with other linkers.

Although I cool with the idea of --as-needed everywhere, we need to fix
bug#347650 in libtool before enabling it. This argument reordering will
also break --no-as-needed when --as-needed becomes the default.

 .''`.      Josselin Mouette
: :' :
`. `'  “If you behave this way because you are blackmailed by someone,
  `-    […] I will see what I can do for you.”  -- Jörg Schilling

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: