[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Full install/removal/upgrade test results available

On Tue, Dec 21, 2010 at 08:37:53PM +0100, Jakub Wilk wrote:
> * Mike Hommey <mh@glandium.org>, 2010-11-19, 09:18:
> >>Mike Hommey <glandium@debian.org>
> >>   python-xpcom (U)
> >
> >I /think/ this could be solved by not using a pre-depends on
> >xulrunner-1.9.1.
> Indeed.
> >OTOH, the pre-depends solves a part of another problem though not
> >entirely, due to triggers ordering: the xulrunner-1.9.1 trigger
> >can't work until the python-support trigger has been run...
> I don't see how pre-depends could have helped here.

I don't remember the details, but it made things half better.

> On the first
> glance it makes it only worse. E.g., when I install python-xpcom in
> a clean chroot I get:
> | Unpacking python-xpcom (from .../python-xpcom_1%3a0.0~hg20100212-2_i386.deb) ...
> | Processing triggers for xulrunner-1.9.1 ...
> | Obtaining the module object from Python failed.
> |
> | <type 'exceptions.ImportError'>: No module named xpcom.server
> | Obtaining the module object from Python failed.
> |
> | <type 'exceptions.ImportError'>: No module named xpcom.server
> When I moved ${xulrunner:Depends} from Pre-Depends to Depends,
> everything was registered just fine.
> >The only fix for that issue that I can think of would be to stop
> >using python-support... If other people have ideas, I'm all ears.
> I think you could manually trigger xulrunner-1.9.1 in python-xpcom's
> postinst if it's not already registered. See the attached patch
> (well, except maybe xulrunner version shouldn't be hardcoded).

I'd expect that to fail as well, because of python-support trigger not
having been run yet.

Part of the problem is that the xulrunner-1.9.1's postinst or trigger can
run with python-xpcom unpacked but not registered with python-support.

Adding update-python-modules -p in python-xpcom postinst could make
things slightly better, but that would still leave xulrunner-1.9.1's
postinst complaining if it's run before python-xpcom's.

What if xulrunner-1.9.1's postinst would do nothing for configure ?
would the trigger still kick in when one installs xulrunner-1.9.1 only?


Reply to: