[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debuild + xvfb-run + Eclipse

Hash: SHA256

On 2010-09-27 20:40, Josh Kelley wrote:
> I'm trying turn an Eclipse CDT (C/C++ Developer Tools) managed build project
> into a Debian package and am having a lot of trouble.  Since it's a managed
> build project, I can't simply run make.  Eclipse can start a build from the
> command line (as described at
> http://stackoverflow.com/questions/344797/962610#962610), but it apparently
> still requires an X server.  I tried using xvfb-run to accommodate, and I
> simply can't get it to work.  xvfb-run works if I invoke it directly, but
> whenever it's invoked from debuild, Eclipse locks up.  I've tried a few
> different approaches to fixing it:  I tried using -e for xvfb-run to see
> errors, but nothing looked relevant; I tried running xvfb-run from fakeroot,
> to see if fakeroot was the source of the problems, but it worked; I checked
> my environment variables, to see if debuild was stripping something that
> Eclipse + xvfb-run needed, but nothing looked relevant.
> Any suggestions?  Any known issues or gotchas in running xvfb-run from
> debuild?  What's different about debuild spawning xvfb-run versus spawning
> it myself?


Perhaps you could convince your upstream of using a non-eclipse build
system with eclipse plugin support (e.g. autotools using the integration
plugin provided by the LinuxTools project[1]).


[1] http://www.eclipse.org/linuxtools/projectPages/autotools/

Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


Reply to: