[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#597618: ITP: libdist-zilla-plugin-prepender-perl -- prepend lines at the top of your perl files

Package: wnpp
Owner: Dominique Dumont <dominique.dumont@hp.com>
Severity: wishlist
X-Debbugs-CC: debian-devel@lists.debian.org,debian-perl@lists.debian.org

* Package name    : libdist-zilla-plugin-prepender-perl
  Version         : 1.101590
  Upstream Author : Jerome Quelin
* URL             : http://search.cpan.org/dist/Dist-Zilla-Plugin-Prepender/
* License         : Artistic or GPL-1+
  Programming Lang: Perl
  Description     : prepend lines at the top of your perl files

This Dist::Zilla plugin will prepend the specified lines in each Perl module 
or program within the distribution. For scripts having a shebang line, lines 
will be inserted just after it.

This is useful to enforce a set of pragmas to your files (since pragmas are 
lexical, they will be active for the whole file), or to add some copyright 
comments, as the fsf recommends.

http://config-model.wiki.sourceforge.net/ -o- http://search.cpan.org/~ddumont/
http://www.ohloh.net/accounts/ddumont     -o- http://ddumont.wordpress.com/

Reply to: