[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dkms needs a pre-depends entry (Policy 3.5)

On 07/17/2010 05:49 PM, Julien Cristau wrote:
> This looks to me like a missing dependency on lsb-release in
> nvidia-kernel-dkms, not in dkms.  And I don't understand why a
> Pre-Depends would be necessary anywhere.  Care to explain?

nvidia-kernel-dkms postint runs /usr/lib/dkms/common.postinst (added by
dh_dkms) so imho this is not a missing dependency in nvidia-kernel-dkms.

Anyway you are right, I was under the impression that lsb-release was
used in preinst, and not in postinst. So a Depends entry is sufficient,
I will fix that soon.


Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: