[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: need help of Octave language expert


I'm cc'ing debian-devel, so people see that there is an answer. If
whoever wants to continue the discussion, please strongly consider
dropping debian-devel -- the list is noisy enough.

On Wed, Mar 10, 2010 at 12:06:06PM +0900, Atsuhito Kohda wrote:
> Hi all,
> I, a maintainer of TeXmacs, try to make TeXmacs as sane
> as possible before squeeze release.
> I noticed recently that if one starts Octave plugin under 
> TeXmacs, it displays an error messages as follows:
> -----------------
> parse error near line 8 of file 
> /usr/share/texmacs/TeXmacs/plugins/octave/octave/.octaverc
>   syntax error
> >>>    gset terminal postscript eps enhanced color;

Directly accessing gnuplot (which is what 'gset' did) is deprecated in
octave3.0 and even more in the 3.2 series. Spending time on this issue
is probably wasted, unless TeXmacs' upstream is willing to adapt the
necessary changes.

it seems Mansour Moufid wanted to take over maintenance of the plugin. I
suggest getting in contact with him.

> I attach problematic files mentioned in the above messsages.
> If someone finds any fix, I greatly appreciate.

In essence, the plot commands in the file need a rewrite. Sorry, but my
problem is just the other way round: I have zero knowledge about


Reply to: