[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#557303: ITP: libmoosex-role-withoverloading-perl -- Moose extension for roles that support overloading

Package: wnpp
Owner: Jonathan Yu <jawnsy@cpan.org>
Severity: wishlist
X-Debbugs-CC: debian-devel@lists.debian.org,debian-perl@lists.debian.org

* Package name    : libmoosex-role-withoverloading-perl
  Version         : 0.03
  Upstream Author : Florian Ragwitz <rafl@debian.org>
* URL             : http://search.cpan.org/dist/MooseX-Role-WithOverloading/
* License         : Artistic or GPL-1+
  Programming Lang: Perl
  Description     : Moose extension for roles that support overloading

 MooseX::Role::WithOverloading allows you to write a Moose::Role which defines
 overloaded operators and allows those operator overloadings to be composed
 into the classes/roles/instances it's compiled to, while plain Moose::Roles
 would lose the overloading.

Reply to: