[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Minimal kernel version raised to 2.6.27

Julien Cristau <jcristau@debian.org> writes:

> On Wed, Nov 11, 2009 at 16:45:58 +0100, Goswin von Brederlow wrote:
>> According to "man 2 open":
>>        O_CLOEXEC (Since Linux 2.6.23)
>> So why does using this flag require 2.6.27? Who is wrong here?
> If you'd actually bothered to look at the changes in question, you would
> have noticed that there's more syscalls than just open(2).
> inotify_init1() was added in 2.6.27, e.g.  Not that I'd expect you to do
> your homework.
> Cheers,
> Julien

Homework: Find out how

    I uploaded a 147-2 package which reverts the O_CLOEXEC change and
    allows 2.6.26, let's see if it works. 

translates to

    I stop using inotify_init1().

Thank you for presenting information in the most agressive way.


Reply to: