[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: MBF: embedded copies of Python modules

]] anatoly techtonik 

| Do you mean that all these packages need to stick to the stable
| standard version of some Module available in Debian? I personally
| think that fit is a bad idea, because by upgrading such Module it is
| possible to break Python Application that require older version of the
| Module for its equivalent stable version.

Then that package should bump its API version and so break compatibility
with all applications that try to use the old API, just like libraries
bump their SONAME when they break backwards compatibility.

Yes, this is painful, and this is one of the reasons why you should be
careful when designing APIs.

Tollef Fog Heen
UNIX is user friendly, it's just picky about who its friends are

Reply to: