[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#550031: ITP: libjs-extjs -- a cross-browser JavaScript library

Package: wnpp
Severity: wishlist
Owner: Thomas Goirand <thomas@goirand.fr>

* Package name    : libjs-extjs
  Version         : 3.0.0
  Upstream Author : Ext JS LLC <licensing@extjs.com>
* URL             : http://www.extjs.com/
* License         : GPL-3
  Programming Lang: Javascript, PHP
  Description     : a cross-browser JavaScript library

 A cross-browser JavaScript library for building rich internet applications.
 The Ext JS library is widely use in numerous web applications. It includes:
 high performance, customizable UI widgets, well designed and extensible
 Component model, qn intuitive, easy to use API, Commercial and Open Source
 licenses available.  Ext JS supports all major web browsers including:
 Internet Explorer 6+, FireFox 1.5+ (PC, Mac), Safari 3+, Opera 9+ (PC,

Ext products are used by companies all over the world across many industries.
Listed below are just a few of those companies:

    * Adobe
    * Aetna
    * AIG
    * Alcatel-Lucent
    * Amazon.com
    * Best Buy
    * Boeing
    * Borland
    * CA
    * Canon
    * Capgemini
    * Cisco
    * CNN
    * Dow Jones & Co.
    * EMC
    * Fidelity
    * General Electric
    * Hallmark
    * HP
    * HSBC
    * IBM
    * Mott MacDonald
    * NATO
    * NetApp
    * Nortel
    * Northrop Grumman
    * Panasonic
    * Pixar Animation Studios
    * Qualcomm, Inc.
    * S&P
    * SAP
    * Siemens
    * Sony
    * Symantec
    * Visa International

So I believe it's becomming increasingly important to have this library
included in main, as it's the base of many web applications that we would
potentially want to include in Debian as well. After I got this library
uploaded into Debian, I am wishing to work on some web apps that are using
it, namely eXtplorer (an Ajax web file manager, which is important to me
as none are included in Debian even if 100s are available for download on
the web), ARIA Tree (as I need it for our web hosting panel DTC), and maybe
more if I have time.

-- System Information:
Debian Release: 5.0.3
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Reply to: