[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#549626: ITP: libvdpau -- Video Decode and Presentation API for Unix. This library provides free wrapper of the Video Decode and presentation API.

Package: wnpp
Severity: wishlist
Owner: "Jean-Yves Avenard" <jyavenard@gmail.com>

* Package name    : libvdpau
  Version         : 0.2
  Upstream Author : Aaron Plattner <aplattner@nvidia.com>
* URL             : http://cgit.freedesktop.org/~aplattner/libvdpau
* License         : Nvidia free
  Programming Lang: C
  Description     : Video Decode and Presentation API for Unix. This library provides free wrapper of the Video Decode and presentation API.

A few weeks ago, nvidia announced that their vdpau wrapper library was
going to be split/removed from the nvidia driver distribution
( first announced in : http://www.nvnews.net/vbulletin/showthread.php?t=138880)

Currently, all vdpau libraries are packaged with nvidia driver (in
particular nvidia-xxx-libvdpau)
Stephen Warren from nvidia submitted various bugs describing what
structure should be adopted, like here:

The main downside with the current nvidia / vdpau drivers as they are
packaged now, is that any packages built using VDPAU (mythtv,
mplayer), has a dependency on a specific nvidia drivers version.

As you can't switch graphic drivers easily...

I've built nvidia drivers without libvdpau, as per nvidia instructions
moving libvdpau to its own separate package.

I was wondering what is the best way to submit it to debian/ubuntu ?

Two modifications are required.
libvdpau package (that includes libvdpau0 and libvdpau-dev)

and the nvidia drivers to explicitely exclude libvdpau and
libvdpau_trace (or more accurately, not remove how they are included

Here is libvdpau package source code:

nvidia drivers for use with new libvdpau:



Then all packages with a build dependency to nvidia-xxx-libvdpau-dev
should be changed to libvdpau-dev
And now packages should now directly reference any nvidia-xxx-libvdpau
package or link with libvdpau_nvidia.so

I'm happy to modify libvdpau package in any ways you see fit and
maintain it in the future...

Thank you

-- System Information:
Debian Release: 5.0
  APT prefers jaunty-updates
  APT policy: (500, 'jaunty-updates'), (500, 'jaunty-security'), (500, 'jaunty')
Architecture: amd64 (x86_64)

Reply to: