[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: library-related policy question

Nikita V. Youshchenko wrote:
> Hi
> Is there an statement in Debian Policy that explicitly requires higher 
> version of a shared library package to be backwards-binary-compatible with 
> previous versions of the same package?
> I mean, is a situation when after library package upgrade local binaries 
> stops working because of missing symbols, by definition an RC bug against 
> library package? Or is depends on particular situation?

Yes, it's an RC bug. If you break the API and/or ABI, you need to change the
package name and the SONAME.

See e.g.


Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: