[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

How to avoid device name related kernel panics after dist(/automated kernel)-upgrade

On Sun, Sep 12, 2004 at 12:23:32PM +0300, Martin-?ric Racine wrote:
> Package: grub
> Severity: important
> I have been wondering for a long time why the menu.lst gets automatically
updated on a single host out of my whole 
> i386 cluster.  The answer seems to be that update-grub won't
automatically run whenever upgrading or removing 
> kernel-images, because the following hooks are missing in
> # Update the GRUB menu
> postrm_hook = /sbin/update-grub
> postinst_hook = /sbin/update-grub
> Given how Debian standardizes on GRUB starting with Sarge, it would be
important that GRUB's installation scripts add
> the above lines to /etc/kernel-img.conf automatically, upon installing or
upgrading GRUB.  This would be easy to
> implement and would save the end-user a lot of troubles, thus making
Debian more user-friendly.

Dear Debian Developers.

you receive this mail because I just cant get a clear view how to solve my
following problem and to which bug it belongs to. Please dont bite my head
(filing a new bug probably would be even worse).
In the hope to get a clearing answer I CC debian-devel.

Applying a recent security update of linux-2.6 (DSA-1872-1) in lenny the
system suddenly seemed unbootable (at least for a person without any debian
The reason was a _silent_ reconfiguration of device names.

My wish:
* please provide a (half) automated, maybe interactive, way to verify the
configuration of fstab / menu.lst (and related) in any matching postinst
* in #debian-devel i got the hint to switch from device names to UUIDs - is
there a way to provide this automatically?
* will UUIDs according to rfc4122 ever be default in debian?

To me this problem doesn't seem to be grub specific, or do LILO and GRUB2
have a solution for it?

#271269 grub - how to deal with /etc/kernel-img.conf and update-grub on
kernel-image changes
  "Maybe dpkg triggers is the answer (we have a separate bug for that,

#499176 grub - should fail verbosely when root device cannot be found
  "update-grub needs to identify the current root in order
to construct grub.cfg / menu.lst.  fstab was not reliable, so it's no
being used."

#510223 grub - linux-image-2.6.26-1-686: upgrade from etch to lenny fails
in postinst
  "update-grub is supplied by grub, this looks like #499176."

Please do whateever you think should be done (except punching me :)

Have a nice day!

Reply to: