[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#542789: ITP: ubuntu-dev-tools -- useful tools for Ubuntu developers

Package: wnpp
Severity: wishlist
Owner: Lucas Nussbaum <lucas@lucas-nussbaum.net>

* Package name    : ubuntu-dev-tools
  Version         : 0.75
  Upstream Author : Ubuntu developers
* License         : Mix. GPLv{2,3} (or later)?
  Programming Lang: mostly python, some shell
  Description     : useful tools for Ubuntu developers

Currrent long description of the package in Ubuntu (might be improved):
 This is a collection of useful tools that Ubuntu developers use to make
 their packaging work a lot easier.
 Such tools can include bug filing, build rebuilding, packaging
 preparation and package analysis, among other things.

This package is similar to devscripts, and some of the scripts it
contains could probably be moved to devscripts. But it also provides
scripts that are useful to Ubuntu developers when running Debian, and
even to Debian developers. For example, requestsync would allow Debian
developers to request syncs (unmodified copies) if their debian packages
to Ubuntu, and pull-lp-source is a dget wrapper that allows to download
source packages from launchpad.

I would appreciate co-maintainers that package. In fact, if someone
wants to do all the work and maintain it by himself, I'm fine with that.

Packaging ubuntu-dev-tools requires packaging some dependencies first:
- python-launchpadlib (Launchpad web services client library)
- python-wadllib (Python library for navigating WADL files)
- python-httplib2 (HTTP client library ; currently packaged but outdated
  in Debian)

- Lucas

Reply to: