[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

depending on obsolete packages

One finds packages depending on obsolete packages, e.g.,
# aptitude -F %p search ?obsolete | xargs -n 1 echo aptitude why|sh -x
+ aptitude why libicu38
i   gimp            Depends libwebkit-1.0-1 (>= 1.0.1)
i A libwebkit-1.0-1 Depends libicu38 (>= 3.8-5)
+ aptitude why libltdl3
i   php5-mcrypt Depends libltdl3 (>= 1.5.2-2)
+ aptitude why libvolume-id0
i   hal Depends libvolume-id0 (>= 0.113-1~)
+ aptitude why linux-image-2.6.26-1-686
i   linux-image-686 Depends linux-image-2.6.26-1-686
Bugs have been filed for all of them, but can't there be an automatic
check added to the system to stop or warn somebody?

Reply to: