[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Forcing version on dependency, how?


I'm trying to build a package so it depends on a specific version of a library.

I carefully read http://www.debian.org/doc/maint-guide/index.en.html

but didn't get the answer I was looking for.

In my debian/control file I have for a given package:
Depends: ${misc-depends}

Which will install all the dependencies as required ; however it
creates a dependency on a newer library I previously installed which
doesn't ship with the system. I know that my package will work with
the standard library.

Is there a way to force which version of the dependency is going to be
Like right now, my package automatically add a dependency to version
1.0.19 of the library, I want that dependency to be on version 1.0.17

The only way I've found so far is to remove ${misc-depends} and set
manually all the dependencies..
But obviously this isn't an ideal solution, as I could very easily
forget about a dependency in the future.

What I tried to do is in the debian/rules add:
dh_makeshlibs -a -V 'libname (>= 1.0.17)'

but this still generate a dependency as:
shlibs-depends=libartsc0 (>= 1.5.9), libname (>= 1.0.17), libname (>> 1.0.19)

Which I don't know how it will behave...

Is there a way to get the dependency to be automatically generated ;
as well as specifying a given version of a dependency?

Any help or recommendations would be greatly appreciated.

Thank you

Reply to: