[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: emboss: FTBFS when converted to new source format 3.0 (quilt): non-unidiff patch

Le Mon, Jun 09, 2008 at 12:01:02AM +0200, Raphael Hertzog a écrit :
> To prepare a possible switch to the new source package format "3.0
> (quilt)" [1], I converted all source packages and tried to rebuild them.
> Unfortunately, emboss failed, you can try yourself with those
> commands (and dpkg-dev >= 1.14.19 [2]) :
> In the case of emboss, the patch
> emboss-5.0.0/debian/patches/patch-1-9 is not in unified diff format.
> Please convert it. quilt refresh can do this for you.

Bonjour Raphaël,

Since the discussion started. I take the opportunity of asking a question with
one of my packages as example. I ask it on -devel because I wonder if it is a
cornercase or if it would concern more persons.

The software suite EMBOSS is released once per year, and any other upstream
change is done through an official monolithic patch. The Debian emboss source
package applies this upstream patch using quilt, but conversion to source
format 3.0 (quilt) does not work because the patch is not in the 'unified'


Since despite it is not unified, this the patch is very well accepted by quilt,
do you think it would be possible to make format 3.0 (quilt) accept this format
as well ? The motivation is to stay as identical as possible to Upstream
material (the only modification I make is to add an explanatory header).

Have a nice day,

Charles Plessy
Debian Med packaging team,
Tsurumi, Kanagawa, Japan

Reply to: