[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#503907: diffstat

On Thu, Dec 25, 2008 at 03:43:35PM +0000, Neil McGovern wrote:
> On Wed, Dec 24, 2008 at 12:23:03AM -0500, Asheesh Laroia wrote:
> > I have a feeling that the libwebkit currently in sid and lenny is pretty  
> > broken, from the looks of this bug.
> >
> Unfortunately, we don't seem to be able to get much/any response from
> the maintainers. It would have been really useful to have a comment
> recently.
> > Is there any way that this library can be permitted to enter testing with 
> > all these changes?
> >
> Not really, no.
> > * Find the fix for this issue and backport it on top of 1.0.1-4
> This would be preferred.
> > * Remove libwebkit-1.0-1 from lenny
> Possible, but not something I'm too happy with given it's popcon.
More than its popcon, the real problem is its reverse dependencies, some
of which can't be removed without massive work on the packages, because
they do provide alternatives (think epiphany, liferea, ...).

> > * Simply allow lenny to release with 1.0.1-4 that is this broken.
> >
> Could anyone confirm how broken this is? Is it all sites, or a
> selection? Maintainers: do you have an opinion on this bug?

According to upstream, a new release was due soon after I uploaded to
experimental, but hasn't happened yet. I may be part of the reason for
the delay because of my lack of time to test the build on all
architectures (and the experimental buildd network still hasn't got
mips or arm...)

According to upstream, still, a lot of bugs have been fixed between
1.0.1 and the version in experimental right now, and FWIW, the BTS
already has 5 such crash bugs that are fixed in experimental.

Anyways, I think libwebkit-1.0-1 is one of these few packages that it
would be good to have in the release, yet we can't guarantee it works
properly. Maybe we should have a special "unsupported" section for
stable, or we should allow packages to ship with some of their
dependencies only fulfilled from unstable, which would state their
unsupported status.

Anyways, I will check again with upstream what the plans are for
this new release and will keep you posted.


Reply to: