[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ITP: mpi-defaults -- Meta-packages depending on appropriate MPI -dev and -bin packages for each platform

On 19 November 2008 at 09:40, Adam C Powell IV wrote:
| Package: wnpp
| Severity: wishlist
| Package name: mpi-defaults
| Version: 0.1 
| Author: Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
| License: Undetermined
| This new source package will produce two binary meta-packages:
| default-mpi-dev and default-mpi-bin which depend on libopenmpi-dev and
| openmpi-bin respectively on the platforms where they are available, and
| lam4-dev and lam-runtime on the others.  A third default-mpi-dbg might
| also depend on libopenmpi-dbg, though there is no corresponding lam
| package.
| Background:
| http://lists.debian.org/debian-science/2008/10/msg00097.html 

Good stuff!   The only question I have is with respect to the naming.  We
sometimes call preferences 'sensible-$FOO'.    I don't really like


because is stresses 'default' as the first word. Apt-get search reveals that
we have exactly one precedent in default-java-*. 

I think we should put either debian or mpi first. How about 


or even


to make it even clearer that it is just 'us' (ie Debian) defining a default
for us, rather misconstruing that more than two decades (I'm guessing) of
competing mpi implementations have ended ? ;-)

Comments ?


Three out of two people have difficulties with fractions.

Reply to: