[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Xen status in lenny?

Hash: SHA1

Hello Bastian,

Bastian Blank escreveu:
> Should actually sign this.
> On Wed, Sep 17, 2008 at 06:52:38PM +0200, Bastian Blank wrote:
>> Checksums:
> | fdf0c5dd755146ad2b631a60b02e90aa39a20d91  linux-headers-2.6.26-1-xen-686_2.6.26-6_i386.deb
> | 90e62bb5548945e19620c6aa0b04b3fc532bc090  linux-headers-2.6.26-1-xen-amd64_2.6.26-6_amd64.deb
> | e4bcee9c5d8f1d23c915e56487f51ecb82f405ac  linux-image-2.6.26-1-xen-686_2.6.26-6_i386.deb
> | 414f9d9c31cfaccbf595011c21b860bb33c56232  linux-image-2.6.26-1-xen-amd64_2.6.26-6_amd64.deb
> | db1c10f13b4972a9ed6a2d834f3c14c858e162e7  linux-modules-2.6.26-1-xen-686_2.6.26-6_i386.deb
> | 57000e8ff722dad5b5dd027f3b6f487ad0a22ea5  linux-modules-2.6.26-1-xen-amd64_2.6.26-6_amd64.deb
> | 5faad1f7e42d8bab766e01a109fd6b50799aa5f5  xen-linux-system-2.6.26-1-xen-686_2.6.26-6_i386.deb
> | b06d9c5373927db34787bddfd9b455dec0bf2a8f  xen-linux-system-2.6.26-1-xen-amd64_2.6.26-6_amd64.deb

   I tried to use these packages by installing them on my home machine,
which currently runs Debian unstable updated everyday.

   First of all, I should say that after downloading
linux-image-2.6.26-1-xen-686_2.6.26-6_i386.deb and
linux-modules-2.6.26-1-xen-686_2.6.26-6_i386.deb I checked their
sha1sums and they matched the ones you listed above.

   Here's what I got while trying to install them :

andrelop@foolish:~$ export LC_ALL=C && sudo dpkg -i
(Reading database ... 125794 files and directories currently installed.)
Preparing to replace xen-linux-system-2.6.26-1-xen-686 2.6.26-6 (using
xen-linux-system-2.6.26-1-xen-686_2.6.26-6_i386.deb) ...
Unpacking replacement xen-linux-system-2.6.26-1-xen-686 ...
Preparing to replace linux-image-2.6.26-1-xen-686 2.6.26-6 (using
linux-image-2.6.26-1-xen-686_2.6.26-6_i386.deb) ...
Unpacking replacement linux-image-2.6.26-1-xen-686 ...
Preparing to replace xen-linux-system-2.6.26-1-xen-686 2.6.26-6 (using
xen-linux-system-2.6.26-1-xen-686_2.6.26-6_i386.deb) ...
Unpacking replacement xen-linux-system-2.6.26-1-xen-686 ...
More than one copy of package xen-linux-system-2.6.26-1-xen-686 has been
 in this run !  Only configuring it once.
dpkg: dependency problems prevent configuration of
 xen-linux-system-2.6.26-1-xen-686 depends on
xen-hypervisor-3.2-1-i386-pae | xen-hypervisor-3.1-1-i386-pae; however:
  Package xen-hypervisor-3.2-1-i386-pae is not installed.
  Package xen-hypervisor-3.1-1-i386-pae is not installed.
dpkg: error processing xen-linux-system-2.6.26-1-xen-686 (--install):
 dependency problems - leaving unconfigured
Setting up linux-image-2.6.26-1-xen-686 (2.6.26-6) ...
update-initramfs: Generating /boot/initrd.img-2.6.26-1-xen-686
Errors were encountered while processing:

   It seems the problem is that xen-linux-system-2.6.26-1-xen-686
depends on xen-hypervisor-3.2-1-i386-pae | xen-hypervisor-3.1-1-i386-pae
but unstable doesn't have these packages. Unstable has only
xen-hypervisor-3.2-1-i386 and it doesn't provide

   Actually, I don't know if xen-hypervisor-3.2-1-i386 should provide
xen-hypervisor-3.2-1-i386-pae or not, I'm just reporting this. I know
that there were some changes regarding PAE support on Xen upstream, but
I don't know how it reflected on Xen packaging on Debian.

   Anyway, I tried booting the dom0 provided by your
linux-image-2.6.26-1-xen-686_2.6.26-6_i386.deb package and the machine
actually came up. I couldn't install any tool for creating VM later
(xen-tools, virtinst, virt-manager, etc) as the package dependency
systems were all trying to "fix" my system after the problem left by the
error reported earlier on this message when installing these packages.

   I had no more time left to use this machine as a testbed so I
rebooted on my usual 2.6.26-1-686 (non-Xen) kernel again to get some
work done.

   However, I noticed the Xen kernel giving some WARNINGs when i booted
it and later asking me to install a "xen-friendly" version of
glibc/libc6 or moving my /lib/tls to /lib/tls.disabled unless I wanted
to my system to become slow.

   Actually, I installed libc6-xen and I have no /lib/tls so I don't
know what could me done to fix this situation. I'm attaching (gziped)
the dmesg from dom0, which shows all the warnings and the message about
the "xen-friendly" libc.

   What I noticed, as the boot message said, was that the system became
really slow after I booted the Xen kernel. Running aptitude took two or
three times more time than running it under a non Xen-enabled kernel,
for example.

   I don't know if it was some mistake I did (probably), but it would be
nice if you could tell me if I should have done my testing in any other
way. I'll probably have a QuadCore machine at work which I could test it
in the next two or three days, so I woul be glad to test it there.


- --
André Luís Lopes
Public GPG KeyID : 9D1B82F6

Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Attachment: dmesg-dom0.gz
Description: GNU Zip compressed data

Reply to: