[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: glib inconsistencies in testing

On Sun, Jul 20, 2008 at 12:41:34PM +0200, Frank Küster wrote:

> since a couple of days ago, I keep getting this message on a lenny
> system during the configure phase of (seemingly) arbitrary packages:

> Setting up samba-common (2:3.0.31-1) ...
> *** This build of Glib was compiled with glib 2.16.4, but is currently
> running with 2.16.3, which is too old.  We'll continue, but expect
> problems!

If you're seeing this from samba-common, the culprit will have to be
debconf (-> libglib-perl).

> It seems like some package which is frequently used in postinsts
> declares insufficiently strict dependencies on libglib.  Before I start
> playing around with postinst scripts, is this issue known and reported?

Actually, the bug is that libglib-perl is second-guessing glib's package
dependencies and spitting out warnings that it shouldn't.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                    http://www.debian.org/
slangasek@ubuntu.com                                     vorlon@debian.org

Reply to: