[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

x11proto-core 7.0.13 will break Tk


I'd like to ask if there are plans to update x11proto-core to version
7.0.13 before lenny release?

Upstream maintainers have added a new event GenericEvent which breaks
Tk toolkit because Tk uses hardcoded event numbers and adds its own
events (see [1]). Gentoo system is already affected (see [2]).

As far as I can see there's no fix which would retain binary compatibility yet.

Certainly affected packages are tk8.3, tk8.4, tk8.5, blt, tile. Also
perl-tk and ruby are likely to break after possible upgrade of
x11proto-core. (May be other packages which use Tk.)

So, if the upgrade of x11proto-core is planned then we have to find an
acceptable fix for Tk now. Otherwise we have some time to wait for a
solution from upstream.

[1] http://sourceforge.net/tracker/index.php?func=detail&aid=2010422&group_id=12997&atid=112997
[2] http://bugs.gentoo.org/show_bug.cgi?id=225999
Sergei Golovan

Reply to: