[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#479220: perl upgrade fails

On Tue, 06 May 2008, Niko Tyni wrote:
> > > I think making liblocale-gettext-perl Pre-Depend on ${perl:Depends}
> > > would fix this particular issue, but I'm worried that it's not the
> > > only one. The other two XS modules that debconf-i18n depends on,
> > > libtext-iconv-perl and libtext-charwidth-perl, come to mind first.
> > 
> > Indeed. CCing debian-devel to see if we have other solutions to avoid the
> > pre-dependency.
> Thanks.

While inspecting the liblocale-gettext-perl changelog, I noticed that I
removed the Pre-Depends in 1.05-2 for wrong reasons (I had only read
the explanation in the 1.05-1 entry and skipped the real explanation in

We already had this issue with the perl 5.6 -> 5.8 move, see

So I'll add the pre-dependency back but we might want to investigate
the work-around mentionned in the bug above to avoid other
similar bugs with debconf usage... (thus CCing debconf maintainers).

> > Another solution is to make sure that the eval construct copes well with
> > XS modules linked for another perl (ie if they fail at dlopen()). I don't
> > see a reason why this couldn't be a run-time failure like another one...
> > 
> > That would be the general solution.
> Right, but it doesn't help for the 5.8 -> 5.10 transition, as the problem
> bites when the old perl-base is still installed. I'm cloning a separate
> 'important' bug for it - while it would be good to get it fixed for
> lenny to ease future transitions, I suppose we can release without it
> if we have to.

See the bug log above for a start maybe.

Raphaël Hertzog

Le best-seller français mis à jour pour Debian Etch :

Reply to: