[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#476482: ITP: ocamlpam -- OCaml bindings for the PAM library

Package: wnpp
Severity: wishlist
Owner: Stephane Glondu <steph@glondu.net>

* Package name    : ocamlpam
  Version         : 1.0
  Upstream Author : Sharvil Nanavati <sharvil.nanavati@gmail.com>
* URL             : http://sharvil.nanavati.net/projects/ocamlpam/
* License         : MIT
  Programming Lang: C/OCaml
  Description     : OCaml bindings for the PAM library

OCamlPAM is a wrapper for the Pluggable Authentication Modules (PAM)
library. PAM provides a flexible mechanism for authenticating users
via administrator-defined policies. PAM has modules for authenticating
via Unix passwd files, Kerberos, LDAP, etc. Additional modules for
custom authentication mechanisms can be created and deployed without
recompiling existing services based on PAM. Moreover, policies
defining the authentication requirements can be changed at runtime
without restarting running services.

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.24-1-686 (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Reply to: